Deprecated: mysql_connect(): The mysql extension is deprecated and will be removed in the future: use mysqli or PDO instead in /storage/content/12/177812/ on line 24 Hesslow Extensions
Samuel Plentz2009-12-11 11:10:11
In Thunderbird 2 everything is ok, but in TB 3 "[[Cursor]]" is NOT replaced by the cursor. It also doesnt get removed.
WizKid2009-12-11 12:13:41
Could you send me the HTML-template that you use? ( emil AT hesslow DOT se )
Samuel Plentz2009-12-11 12:54:26
Its not a HTML-Template.

But it also happens with HTML-Templates:

Sample Template I am using:
Hi [[TO=firstname]]


Kind regards

A very simple Template not working:

Or even the simplest Template:

BTW: Win 7 here and TB 3.0 Final.
Samuel Plentz2009-12-11 12:55:43
Little mistake - I wanted to write:

Or even the simplest Template:
Samuel Plentz2009-12-11 12:58:14
BTW: Someone else has the same Problem. He wrote on
(in his rating)

Cursor position variable invalid

The cursor position variable invalid.
(windows 7 + thunderbird 3.0)
WizKid2009-12-11 23:55:21
Do you edit your emails as HTML? Because when I tested it it worked. I don't have Windows 7 but it feels strange that that would effect.
Samuel Plentz2009-12-12 01:26:31
Yes I write HTML emails, but the same happens if I switch to plain text mails. Just tried it in Vista with the same effect.

There are no problems with TB 2 and Quicktext on Vista and Win7. (Only with TB 3 and Quicktext)

You surly tried TB3 with Quicktext...
What exactly is your code when replacing the "[[Cursor]]" in TB3?
Samuel Plentz2009-12-12 01:28:43
BTW: I could test some debug or bugfix version if you want.
daemon2009-12-12 07:32:13
I have the same issue - [[CURSOR]] doesn't work, + TB3.0, Win2003
variable stay unchanged in the email as it is: [[CURSOR]]
and cursor places to the end of the email (template).
WizKid2009-12-12 18:22:23
Samuel: My test looks like this:

But now that I think of it I did a small fix to make it possible to insert HTML-templates when you send HTML-mail even if you have set plain text in your profile. It may be that that fixed it. But I will release a new version tomorrow with that bugfix in it and hopefully that solves it.
Samuel Plentz2009-12-12 21:47:45
Your example doesnt change it. ([[CURSOR]] is not replaced - everything else is replaced) (I used insert as HTML)

BTW: I am very glad, that you care about the bug. Its a nice and fast support here.
WizKid2009-12-12 23:38:03
I've uploaded a as a beta version. If you check the extension page there is a link under the Download button. Please test that if the new version fix it. If it doesn't could you tell me exactly what template you test with and how you insert is and so on. To see if I'm doing something different.
Samuel Plentz2009-12-13 02:06:05
The new Version does not change anything.

I looked into your code. The problem here is in Line 411 of quicktext.js:
411: gQuicktextVar.parseCursorTag(editor, newRange);

On execution of this line the following exception is thrown:
[Exception... "Cannot find interface information for parameter arg 0 [wzIQuicktextVar.parseCursorTag]" nsresult: "0x80570006 (NS_ERROR_XPC_CANT_GET_PARAM_IFACE_INFO)" location: "JS frame :: chrome://quicktext/content/quicktext.js :: anonymous :: line 411" data: no]

So the Cursor-Part is never executed.
Perhaps the compiled Interface definitions are outdated in the package?
Samuel Plentz2009-12-13 13:08:01
I found a workaround for the problem: I commented the function call in Line 411 and put the code of the function inline at this place.

Everything works fine now. I will send you the updated plugin per mail.
This is meant to be only a workaround. (I think you should look into the interface definitions.)
Samuel Plentz2009-12-13 14:55:57
The new beta version resolves the issue:
quicktext_0.9.10.1 (updated on 13.12. 15:00!!!)

Everything just works.
jos.jong2009-12-13 23:53:47
I also have this annoying problem. Also still with version (within Thunderbird I found a minimalistic example that maybe can help to fix it.

The following goes wrong: [[CURSOR]]<style></style><div>foo</div>
But this one works: [[CURSOR]]<div><style></style>foo</div>

As you can see the only difference is that the <style> element is now outside the div.
Samuel Plentz2009-12-14 01:20:32
This is not the same issue. The thread is about any [[CURSOR]] Statements that do not work in TB3.

IMO you should have opened a new thread.
Glanskis2010-03-27 18:45:30
I have the same problem (W7, TB3) with the just loaded and installed quicktext_0.9.10.1 . [[CURSOR]] ist not working. Where do I get the beta version, which resolves the problem?

Glanskis2010-03-28 09:49:40
The problem is solved. I just thought I was using version, but it was When downloading it from your homepage with the big download-button (right hand to Quicktext-pro) you get version, when using the download-button under "Extensions" you get .

Thanks a lot for this great extension!
borish2012-11-22 12:21:55
I have the same problem with Quicktext on thunderbird 16.0.2+build1-0ubuntu0.11.10.1.

I use plain text ISO-8859-1 to compose emails. My template is

Best regards,
However, the text [[CURSOR]] is shown in the email.

I can't use Quicktext as it is incompatible with TB 16.
1 2
Create post
You need to login before posting in the forum