Forum
PaulTaylor2017-04-18 21:14:54
Help needed. Since I upgraded to Thunderbird 52, I am having a serious problem with images in my Quicktext templates. These are images stored on my hard drive and used on my Quicktext stationery templates, brochure templates, etc. Thunderbird is automatically blocking each and every image in my templates. When I write a new message and select a Quicktext template. The Thunderbird error message is: "Thunderbird has blocked some files from loading into this message. Unblocking a files will include it in your sent message." However, the only solution that Thunderbird offers is an Option button to select each image individually and unblock them one by one for that particular message. There seems to be no way to permanently stop the blocking altogether. I assume this is some new security feature. Since I frequently have multiple images in a template, Thunderbird's solution is intolerable. Other than returning, to an earlier version of Thunderbird, what can be done?
RDL19842017-04-20 04:45:13
Please see the following item in the TB52.0 release notes. It includes a single solution for all such image links.

Thunderbird — Notes (52.0) — Mozilla

https://www.mozilla.org/en-US/thunderbird/52.0/releasenotes/?buildid=20170413214957&locale=en-GB&os=WINNT&uri=/thunderbird/releasenotes/&version=52.0.1#note-786944


[quote="Mozilla"]IMPORTANT: The way images are included in a compose window has changed. Images are now included as data URIs and not as references to parts of other messages or operating system files. This allows better interoperability with office packages such as MS Office or LibreOffice. Images linked from locations on the internet will no longer be downloaded and attached to the message automatically.

This can be changed

for each image individually via the Image Properties dialog

or globally by setting the preference mail.compose.attach_http_images.[/quote]
PaulTaylor2017-06-30 04:50:46
Is the above “mail.compose.attach_http_images” solution working for anyone? No change for my stationery image templates. Same problem. And I fail to understand how “Image Properties dialog” has anything to do with Quicktext templates. Help?
TJFOE2017-07-13 20:29:20
mail.compose.attach_http_images

... is not working for me!
dpan2017-09-06 20:58:14
Neither for me.
I think that the thunderbird developers messed things up.
dpan2017-09-07 18:51:20
Here is the solution.

You have something like this in your Quicktext Template:
<img src="file://C:Picturesimage.png">

The above has to be replaced with a URI(*) string, the image encoded as text, something like the following:
<img src="data:image/png;base64,iVBORw0KGgoAAA
ANSUhEUgAAAAUAAAAFCAYAAACNbyblAAAAHElEQVQI12P4
//8/w38GIAXDIBKE0DHxgljNBAAO9TXL0Y4OHwAAAABJRU
5ErkJggg==" />
The above represents a red dot. If the image is large the string may be 20Kb or more.

Now, in order to convert your image into a URI type format you may use one of the available online services, such as:
https://www.base64-image.de/
http://dataurl.net/#dataurlmaker
https://websemantics.uk/tools/image-to-data-uri-converter/
https://www.abeautifulsite.net/convert-an-image-to-a-data-uri-with-your-browser

Resources:
https://en.wikipedia.org/wiki/Data_URI_scheme
(*) The data URI scheme is a uniform resource identifier (URI) scheme that provides a way to include data in-line in web pages as if they were external resources.

I hope that the above will help you.
1
Create post
You need to login before posting in the forum